W-tje, Bepaal waarde links van zoekindex !


Het vinden van een waarde links van de zoekindex(kolom) kan op verschillende manieren. Eén van de manieren is het "voor de gek houden" van de formule VERT.ZOEKEN() door de kolommen in het zoekbereik met de formule KIEZEN() om te wisselen. Met KIEZEN kunnen we kolommen in een lijst t.b.v. andere functies "omgooien". Een normale lijst waarbij de zoeksleutel in de eerste kolom van het bereik zou staan zou het zoeken geen problemen opleveren. Stel je wil zoeken naar een waarde in kolom I en als resultaat het op dezelfde rij als de gevonden waarde in "H"kolom Met KIEZEN() draai je de kolommen om door gebruikmaking van de formule:
=KIEZEN({1\2};I:I;H:H)

Het 
eindresultaat in combinatie met de formule VERT.ZOEKEN() ziet er dan als volgt uit. 

=VERT.ZOEKEN(C20;KIEZEN({1\2};I:I;H:H);2;ONWAAR) 

Waarbij C20 de zoekwaarde bevat waarnaar moet worden gezocht.

Probeer het maar eens uit !


Heb je nog vragen, neem dan gerust contact met ons op.

Inloggen Registreren

Inloggen

Mrah Development BV

MRAHDevelopment

Mrah Development BV
Voor uw Excel vragen,
Leuke gratis Excel toepassingen.

ExcelFIX

links_partners_5

ExcelFIX
ExcelFIX herstelt beschadigde
en corrupte spreadsheets die
gemaakt zijn in Microsoft Excel.

Infotron BV


linkspartners_5

www.infotron.nl
Zelf al goed met Excel, maar wilt u bestanden beter begrijpen, valideren en verbeteren?

Exhelp.be

Links_partners_20

ExcelFIX
Dé Vlaamse Excel blog